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System Overview

Welcome to Banner® Document Management (BDM), an imaging and electronic 
document management system that meets the specific needs of higher education 
institutions. BDM integrates Banner with two OpenText document management products: 
ApplicationXtender Document Manager and ApplicationXtender Web Access.

BDM integrates with Banner at the data, event, and form levels. In addition, each Banner 
product (Human Resources, Finance, Financial Aid, Student, and Advancement) has 
specific integration points that improve efficiency and supplement the decision-making 
process through easy access to relevant document collections.

BDM can also be used standalone, outside the Banner environment, to scan documents 
that do not pertain to Banner data.

Note: For specifics about using BDM in a Multi-Entity Processing (MEP) 
environment, refer to the Banner Document Management Multi-Entity 
Processing Implementation Guide.

Functional overview

BDM allows you to manage documents as follows:

• Scan and index documents individually or in a batch.

• Query for specific images or documents from a Banner form.

• Limit the scope of the query based on document type and, where desirable, the cursor 
location on a Banner form.

• E-mail images and documents to other users for review.

• Annotate images.

• Update Banner data based on the receipt of appropriate documents.

• Scan and store documents that do not pertain to Banner data.

• Use the Multi-Entity Processing (MEP) feature if Banner data is segregated by campus 
or institution.

BDM uses Banner security to ensure that users access the appropriate information. This 
security is enforced whether BDM is accessed from Banner, or in a standalone manner.

Integration between Internet-Native Banner (INB) and ApplicationXtender Web Access 
allows you to access ApplicationXtender documents and images through a Web browser.
  4M 8.7.0.6 User Guide with AX 16.3 | System Overview 
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Supporting features in the Banner user interface

The INB toolbar includes the following BDM buttons:

• BDM - Display Document  - This button opens ApplicationXtender Document 
Manager or ApplicationXtender Web Access to run a query from Banner.

• BDM - Add Document  - This button opens ApplicationXtender Document Manager 
or ApplicationXtender Web Access to create a new ApplicationXtender document from 
data stored in Banner.

The INB Tools menu includes the following BDM options:

• Retrieve Documents - This option opens ApplicationXtender Document Manager or 
ApplicationXtender Web Access to run a query from Banner.

• Count Matched Documents - This option runs a query to determine whether supporting 
documents exist for the current Banner record.

• Add New Document/Page - This option opens ApplicationXtender Document Manager 
or ApplicationXtender Web Access to create a new ApplicationXtender document from 
data that is stored in Banner.

• User Preferences - This option allows you to define user-specific settings for default 
BDM behavior.

For specifics about using these features in a Multi-Entity Processing (MEP) environment, 
refer to the Banner Document Management Multi-Entity Processing Implementation 
Guide.
  5M 8.7.0.6 User Guide with AX 16.3 | System Overview 
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Configuration diagrams

The following diagrams show common BDM configurations.

Banner with ApplicationXtender Document Manager

Note: QuickScan Pro provides batch scanning functionality, allowing you 
to scan documents and then index them at a later time in 
ApplicationXtender Document Manager.
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Banner with ApplicationXtender Document Manager and 
ApplicationXtender Web Access

Note: QuickScan Pro provides batch scanning functionality, allowing you 
to scan documents and then index them at a later in ApplicationXtender 
Document Manager.
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BDM Web architecture

BDM components

BDM includes the following components:

• ApplicationXtender (AX) – OpenText suite of content management products that 
facilitate file/object storage, OCR, and other features for document management.

• ApplicationXtender Document Manager – A client/server component of OpenText 
ApplicationXtender product that allows users to access ApplicationXtender content 
management functionality via desktop software, scan and index documents, and index 
batches of documents.

• ApplicationXtender Web Access (WX) – An Internet-native component of OpenText 
ApplicationXtender product that allows users to access ApplicationXtender content 
management functionality via a Web browser.

• QuickScan Pro – A user-based client/server application that is used for batch scanning.

• ApplicationXtender Web Services – An Internet-native component of OpenText 
ApplicationXtender product that uses APIs to integrate with ApplicationXtender. Web 
Services is a flexible alternative to ApplicationXtender CDK methods.

• ApplicationXtender for Microsoft Office (AXO) – An ApplicationXtender product that 
allows users to create, update, and delete documents in BDM applications in 
ApplicationXtender from within a Microsoft Office product, such as Word, Excel, 
PowerPoint and Outlook.
  8M 8.7.0.6 User Guide with AX 16.3 | System Overview 



BD
Accessing ApplicationXtender

This chapter gives instructions for three different ways to access ApplicationXtender:

• Log in to ApplicationXtender Document Manager (standalone).

• Log in to ApplicationXtender Web Access (standalone).

• Access ApplicationXtender from Banner®.

Banner Document Management also supports Central Authentication Service (CAS) 
Single Sign-on, and Ellucian Identity Service (EIS). Instructions for any of these 
authentication protocols are in the product-specific guides published for them.

Log in to ApplicationXtender Document Manager 
standalone

If you are outside the Banner environment, use the following steps to log in to 
ApplicationXtender Document Manager.

1. Launch Programs > ApplicationXtender Desktop > AppXtender Document Manager. 
The login dialog box is displayed.

2. Select a data source.

3. Enter your user name in the User Name field.

4. Enter your password in the Password field.

5. Click Login.

After you log in, a list of Applications is displayed under the data source. Use the following 
steps to log in to a different data source.

Note: If you do not see a list, select View >Applications for the list of 
applications to display when you log in to ApplicationXtender Document 
Manager.

1. In the Application List window, right-click the name of your current data source and 
select Logout.

2. In the Application List window, right-click the name of the data source that you want to 
use and select Login.

3. Enter your user name in the User Name field.

4. Enter your password in the Password field.

5. Click Login.
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Log in to ApplicationXtender Web Access 
standalone

If you are outside the Banner environment, use the following steps to log in to 
ApplicationXtender Web Access.

1. Launch a supported Web browser.

2. Enter the URL for your ApplicationXtender Web Access application. 

The Login window is displayed.

3. Select a data source from the Data Source drop-down list.

4. Enter your user name in the User Name field.

5. Enter your password in the Password field.

6. Click Login.

Access ApplicationXtender from Banner

If you are inside the Internet-Native Banner (INB) environment, you can use the Tools 
menu and the INB toolbar buttons to access ApplicationXtender. Settings on the User 
Preference Form (EXAUPRF) control the default behavior for the Tools menu and the 
toolbar buttons.

Note: For details about accessing ApplicationXtender from Banner in a 
Multi-Entity Processing (MEP) environment, refer to the Banner 
Document Management Multi-Entity Processing Implementation Guide.

User Preference Form (EXAUPRF)

Settings on EXAUPRF control the default behavior when the Tools menu or the toolbar 
buttons are used to access ApplicationXtender from Banner.

Note: If your system administrator sets the Use System Default Setting 
flag to configure universal settings for all users, you may not be able to 
access EXAUPRF.

Use the following steps to specify your preferences for accessing ApplicationXtender from 
Banner.

1. Launch Internet-Native Banner (INB).

2. Access the User Preference Form (EXAUPRF).
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3. In the Default Association Between Banner and AppXtender section, use the 
check boxes to specify which ApplicationXtender product your Banner session 
invokes through the Tools menu or the toolbar buttons.

Note: Set up the Integration URLs on EXAINST to point to 
ApplicationXtender Web Access and the INB-AX Bridge (for 
ApplicationXtender Document Manager). These URLs are used when a 
user invokes ApplicationXtender from one of the two toolbar buttons or 
options under Tools > Banner Document Management.

4. In the Default Source for New Document/Page section, set the default interface that 
is displayed when document creation is initiated in Banner. 

• If you specified AppXtender Document Manager in step 3, this interface might be a 
file browse window or a local scanner interface. The specified interface will be 
displayed when the BDM - Add Document option is initiated from a Banner form.

• If you specified ApplicationXtender Web Access in step 3, the only available option 
is Import File. The specified interface will be displayed when the BDM - Add 
Document option is initiated from a Banner form.

5. Save the record.

6. Exit EXAUPRF.

7. Exit INB.

Tools menu

The Banner Tools menu provides the following options for accessing ApplicationXtender:

• Retrieve Documents - This option opens ApplicationXtender Document Manager or 
ApplicationXtender Web Access, depending on your user preference setting, to run a 
query from Banner.

• Count Matched Documents - This option runs a query to determine whether supporting 
documents exist for the current Banner record. The query result is a pop-up window that 
displays the number of documents found in the BDM application as defined for the 
Banner form in the BDM context rules. Refer to “Context rules” on page 23 for more 
details.

• Add New Document/Page - This option opens ApplicationXtender Document Manager 
or ApplicationXtender Web Access, depending on your user preference setting, to 
create a new ApplicationXtender document from data stored in Banner. Refer to “Attach 
pages to an existing document” on page 21 for more details.

• User Preferences - This option allows you to define user-specific settings for default 
BDM behavior.

Note: If your system administrator sets the Use System Default Setting 
flag to configure universal settings for all users, you may not be able to 
access EXAUPRF.
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Toolbar buttons

The following Banner toolbar buttons can be used to access ApplicationXtender:

• BDM - Display Document  - This button opens ApplicationXtender Document 
Manager or ApplicationXtender Web Access, depending on your user preference 
setting, to run a query from Banner. This corresponds to the Retrieve Documents option 
on the Tools menu.

• BDM - Add Document  - This button opens ApplicationXtender Document Manager 
or ApplicationXtender Web Access, depending on your user preference setting, to 
create a new ApplicationXtender document from data stored in Banner. Refer to “Attach 
pages to an existing document” on page 21 for more details.

System messages

Depending on the Windows operating system on your workstation or ApplicationXtender 
server, you might get one, or both, of the following messages when connecting from 
Banner to ApplicationXtender:

• You might get a Windows popup message asking for permission to open a program on 
your computer. Select the Always ask before opening this type of address check 
box. Then click Allow. 

• You might get an Internet Explorer security message indicating that the Web site wants 
to open Web content using this program on your computer. Select the Do not show me 
the warning for this program again check box. Then click Allow.
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Creating and Indexing Documents

You can use Banner® Document Management (BDM) to store various types of information 
as documents in ApplicationXtender. These documents are organized in applications for 
easy retrieval. Each document is saved with an index that is used to search for the 
document from an Internet-Native Banner (INB) form or to access directly using 
ApplicationXtender Document Manager or ApplicationXtender Web Access. 

Various input methods are available to add documents and pages. You can add 
documents by using a scanner, creating a document from Banner, or importing a file or 
object. You can add pages and page versions to documents after they are created.

This chapter provides information about creating documents, removing documents, 
indexing documents, and attaching pages to existing documents.

Scan documents

You can create new documents from any scanner that is supported by or certified for 
ApplicationXtender Document Manager or ApplicationXtender Web Access. For detailed 
scanning instructions and a list of certified and supported scanners, refer to the OpenText 
documentation for ApplicationXtender Document Manager and ApplicationXtender Web 
Access.

Create new documents from Banner

To create a document or add a page to an existing document, select the  button from 
the toolbar of the applicable Banner form. The following processing occurs:

1. Either ApplicationXtender Document Manager or ApplicationXtender Web Access 
launches, depending on the option selected for Default Association Between 
Banner and AppXtender on the User Preference Form (EXAUPRF). For more 
information, see “User Preference Form (EXAUPRF)” on page 10.

2. In a MEP environment, the value of the institution code for the current INB session is 
stored in the PROCESS_CONTEXT field. The login process between INB and 
ApplicationXtender uses this field to identify the data source when Banner toolbar 
buttons or Tools menu options are used.

For detailed information regarding BDM in a MEP environment, refer to the Banner 
Document Management Multi-Entity Processing Implementation Guide.

3. The native behavior for creating a new document within the loaded application occurs. 
In ApplicationXtender Web Access, the Import File dialog box is displayed. In 
ApplicationXtender Document Manager, depending on your user preferences, either 
  13M 8.7.0.6 User Guide with AX 16.3 | Creating and Indexing Documents 
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the scanner interface is displayed if the Scan option is selected or an Import File 
window is displayed if the Import File option is selected. This activity requires the 
same user input as if the process was initiated directly within the OpenText product.

4. The new file or image is created with the index grid displayed next to the image of the 
new document. Depending on the criteria specified within the context rule for the 
Banner form, you might have all of the index field values populated, or you might need 
to enter some information (for example, document type) before saving the new index.

Note: The BDM Context Determination Form (EXABCXT) contains the 
context and parameter rules for most baseline Banner forms. The rules 
that are passed to ApplicationXtender Document Manager or 
ApplicationXtender Web Access depend on where the cursor is located 
when the toolbar button is selected. Refer to “Using Context Rules and 
Queries” on page 23 for more details.

Creating a document from Banner allows a user to quickly associate a small volume of 
document information with a specific Banner record. This functionality is not a substitute 
for batch processing through QuickScan Pro or scanning and indexing queues.

Import documents

You can create a new document by importing an existing file. You can import any file type. 
If ApplicationXtender Document Manager or ApplicationXtender Web Access supports the 
file type that you import, the contents of the file appear in the Document Display view. If 
the file type is not supported, you need a third-party viewer to display the contents of the 
file. 

For more information on supported file formats, consult the online help for 
ApplicationXtender Document Manager or ApplicationXtender Web Access.

Import and Index documents with 
ApplicationXtender Web Access

Complete the following steps to import and index documents:

Note: Follow the instructions pertinent to the ApplicationXtender Web 
Access privileges you have.

To create a new document using the New Document feature:

1. From Application List view, select the application you want to add the documents to. 

2. Click the file cabinet drawer icon in the toolbar and select UPLOAD NEW 
DOCUMENT. 
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3. In the Upload New Document dialog box, click Choose Files, then select one or 
more files you want to import.

4. With the file path in the File text box, click UPLOAD.

The first page of the imported file appears in the Document Viewer.

5. Enter the index information for the new document and click SAVE.

Note: In the majority of the BDM baseline applications, when you enter 
the first index field and press the Tab key, the key reference data will be 
filled in.

6. To import and index additional documents, select Application Name link on the 
breadcrumb, then repeat Step 1 through Step 5 for each document.

7. Click Logout on the right side of the title bar to exit ApplicationXtender Web Access.

Import and Index documents for 
ApplicationXtender Document Manager

For ApplicationXtender Document Manager, use the following instructions to import and 
index a batch of documents:

1. Right-click the application name in the Application List view.

2. On the application shortcut menu, select New Document > Import File. The Import 
File dialog box appears, allowing selection of any file.

3. Navigate to and select the file that you want to import and click Open. 

The first page of the imported file appears in the viewer in Document Display view.

4. Enter the index information for the new document and click Save.

Note: In most BDM baseline applications, when you enter the first index 
field and press the Tab key, the key reference data will be filled in.

5. To import and index additional document, select File > Close, then repeat Step 1 
through Step 6 for each document.

6. Click File > Exit to close ApplicationXtender Document Manager.

Note: Refer to the Help in the ApplicationXtender Document Manager for 
additional information on importing, scanning, and indexing documents, 
and detailed information on the toolbar buttons available in 
ApplicationXtender Document Manager.
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Indexing documents in a batch in 
ApplicationXtender

ApplicationXtender Document Manager

For ApplicationXtender Document Manager, complete the following instructions to open 
the batch list and index a batch of documents:

1. From the Utilities menu, select Batch Index (List).

The Batch Index dialog box appears.

2. From the Batches for application drop-down list, select an application.

3. From the list of batches, select the batch you want to index.

4. Click Index. 

The Batch Index toolbar appears with the first page of the batch in Document Display 
view. 

5. Click New Document.

Note: Use the Previous Page and Next Page buttons on the Batch Index 
toolbar to navigate to the page where you can create a new document 
from the current batch.

6. Index the new document and click Save. 

Note: All ApplicationXtender indexing features, such as 
ApplicationXtender Auto Index Import ([F7]), Key Reference ([TAB]), and 
appending pages ([F4]), are available when you index documents in 
batches. For details on ApplicationXtender indexing options, refer to the 
Help in the ApplicationXtender Document Manager.

7. To index the next page in the batch, click New on the toolbar.

• When you click New, the data clears from the index fields and the Save button is 
enabled the Index panel.

• Click Attach Page or Attach All to add pages to the most recently indexed 
document.

8. Repeat steps Step 6 through Step 7 for each batch document you want to index.
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9. When all pages in the batch are indexed or added to ApplicationXtender documents, a 
message asks whether you want to index another batch. Click one of the following 
choices:

• Click Yes to index another batch. The Batch Index (List) dialog box appears.

• Click No if you do not want to index another batch. The current batch closes.

Note: Refer the Help in ApplicationXtender Web Access for additional 
information regarding batches.

ApplicationXtender Web Access

For ApplicationXtender Web Access, complete the following instructions to open the batch 
list and index a batch of documents:

1. In the Application List view, use one of these methods to select a batch to index:

• Click the application that contains the batch of documents you want to index, and 
click the file cabinet drawer icon in the toolbar, and select MANAGE BATCHES. If 
batches exist for the selected application, information about those patches appear 
in the list.

2. Choose and open the batch you want to index.

3. On the page displayed in the viewer, in Index view, add the data to the index fields.

Note: In addition to the key fields, populate all non-required fields for 
which data is available so that the document index will be as complete as 
possible.

4. When you finish entering data, click SAVE. 

ApplicationXtender Web Access creates the new ApplicationXtender document and 
stores the physical document electronic file or image file and its index information in 
ApplicationXtender.

The next page in the batch appears in the viewer.

5. To index the next page in the batch, click Create Another Document. 

After you click Create Another Document, the data clears from the index fields and 
the SAVE button is enabled the Index panel.

6. Repeat steps Step 4 through Step 5, until all pages are indexed.

When there are no pages left in the batch, the All Document Pages Have Been 
Indexed dialog box appears.

7. To continue batch indexing, select Index Another Batch Document. If you have 
finished batch indexing, select your choice from the remaining options.

Note: Refer to the Help in ApplicationXtender Document Manager for 
additional information regarding batches.
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Remove documents

For ApplicationXtender Document Manager, there are two ways to delete a document:

• The Result Set tab allows you to delete without displaying the document.

• The Document Display view requires the document to display before deletion.

For ApplicationXtender Web Access, use the following steps to delete a document:

1. Query the application that contains the document that you wish to delete.

2. The query may result in either a Query Results list of documents or display a 
document (if only one is found for the query). Follow the set of steps related to the 
result of the query:

• Query Results list

2.1. Select the document you want to delete.

2.2. Click the DELETE icon on the toolbar. 

A message asks you to confirm the deletion.

2.3. Click DELETE. 

A message confirms that the document has been deleted.

2.4. Click OK.

• Document displayed in Document Viewer.

2.1. Select Document > Delete Document.

2.2. Click DELETE.

2.3. Click OK. 

A message confirms that the document has been deleted.

When a document is deleted, the index information for the document and the 
document pages are deleted.

For more information on deleting a document, consult the online help for 
ApplicationXtender Document Manager or ApplicationXtender Web Access.

Index documents

The index of a document allows for quick, easy retrieval of the document. The more 
detailed and specific the index, the easier it is to retrieve the document in a large system. 
An index should contain all or many criteria that a person might use to search for the 
document.

Several indexing aids are available to help you enter index information. The most 
commonly used aid is the key reference system, available on most applications that are 
delivered with BDM. Another indexing aid is the auto index system. The key reference 
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system and the auto index system complement each other and can be used together to 
quickly index documents to a fine level of detail.

The data in each of these tables is updated on a real-time basis; when a new record is 
added to a Banner table, the key reference or auto index table is updated. This keeps the 
data as current as possible, so that they are available to the BDM user who may add a 
record in Banner, then index a document to it in BDM.

All BDM applications use the VPDI_CODE index field to support the Database Extension 
Utility and Multi-Entity Processing (MEP). This text field is used in a MEP environment to 
identify the campus or institution code to which a document index is assigned. This field 
corresponds to the VPDI_CODE field in a Banner table record in a MEP environment.

Key reference system

You can perform a lookup in the key reference system by entering the key value or by 
performing a search.

Lookups using a key value

Enter the value of the first index field (typically ID in BDM-delivered applications) and 
press Tab to move to the next field or select another field. If the entered value exists in the 
key reference system, then associated (data reference) fields are populated automatically. 

Example

The B-G-ID application includes the following index fields:

ID
PIDM
DOCUMENT TYPE
LASTNAME
FIRSTNAME
SSN
BIRTH DATE
ROUTING STATUS
ACTIVITY DATE
VPDI_CODE
DISPOSITION DATE

Using the key reference system, a user only needs to enter an ID into the index 
structure and press Tab to move to the next field. This action populates data in the 
PIDM, LASTNAME, FIRSTNAME, SSN, and BIRTH DATE fields.
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Lookups using a search

ApplicationXtender Document Manager has the following search features:

• To search against existing documents, press F4. The Result Set list includes a record 
for each indexed document. To narrow the results, enter a specific ID or name in the 
index grid before executing the search.

• To perform a search against unused key reference records (Banner data that has no 
indexed documents) and existing documents, press Shift+F4. The Result Set list 
displays a folder icon next to records that have indexed documents. Selections made 
from this list populate data into the index. To narrow the results, enter a specific ID or 
name in the index grid before executing the search.

ApplicationXtender Web Access has similar search features. These searches are 
performed by clicking the Select Indexes button (analogous to F4) or the Key Reference 
and Indexes button (analogous to Shift+F4). In both cases, the Result Set list can be 
narrowed by entering a specific ID or name in the index grid before executing the search.

Wildcard characters facilitate “fuzzy searches.” The characters for fuzzy searches are an 
asterisk (*) for multiple characters, and a question mark (?) for a single character. 
Wildcard characters may be used in the beginning, middle, or end of an entry.

Examples

Entering an ID value of 1234? yields a result set that includes ID values such as 
12341, 12342, and 12343. 

Entering an ID value of 123* yields a result set that includes all ID values that begin 
with 123 regardless of the number of characters in the ID. 

Lookups in a MEP environment

Enabling a key reference table for MEP segregates data by campus or institution. If the 
key reference table used by a BDM application is enabled for MEP, then the key reference 
lookup returns ID information for the specific campus or institution associated with the 
ApplicationXtender login.

For details about creating and indexing documents using BDM in a MEP environment, 
refer to the Banner Document Management Multi-Entity Processing Implementation 
Guide.

Auto index system

The auto index (AI) system is available for BDM-delivered applications that contain fields 
for Banner data not included in the key reference system (that is, non-finance related 
applications and those other than B-%-ID). 

The AI system contains data that cannot be included in the key reference system without 
creating multiple occurrences of the records. The main observable difference in the two 
lookup systems is the quantity of information available for the same ID.
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To illustrate, if you know someone’s ID you can easily find the name and birth date by 
using the key reference lookup process. However, knowing the ID does not mean that a 
specific tracking requirement, application number, or pledge number can be identified. 
There may be many occurrences of each, distinguished by other data elements such as 
term code or aid year. The AI lookup gains visibility into numerous, related occurrences of 
data.

The AI system can be invoked by pressing F7 key in ApplicationXtender Document 
Manager, or by clicking the Auto Index button on the ApplicationXtender Web Access 
indexing page.

Enabling an auto index table for MEP segregates data by campus or institution. If the auto 
index table used by a BDM application is enabled for MEP, then the auto index lookup 
returns ID information for the specific campus or institution associated with the 
ApplicationXtender login. For details about creating and indexing documents using BDM 
in a MEP environment, refer to the Banner Document Management Multi-Entity 
Processing Implementation Guide.

Attach pages to an existing document

A document can include multiple pages. When page 1 is indexed, a new document is 
established in the system. You can attach pages to an existing document. A document 
does not have to be displayed to attach a page to it.

Attach a page to a document displayed in 
ApplicationXtender Document Manager

Use the following steps in ApplicationXtender Document Manger to attach a page to a 
document that is not currently displayed.

1. Make sure that the existing document is displayed.

2. Select Page > New, then follow the instructions in either Step 3 or Step 4.

3. If you are scanning the new page:

3.1. Select Scan. A shortcut menu is displayed.

3.2. Select the location for adding the page (before the current page, after the 
current page, or at the end of the document). ApplicationXtender scans the 
page and attaches it to the displayed document.

4. If you are importing the new page:

4.1. Select Import File. A shortcut menu is displayed.

4.1. Select the location for adding the page (before the current page, after the 
current page, or at the end of the document). The Import File dialog box is 
displayed.
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4.2. Navigate to and select the file that you want to import. 

4.3. Click Open. ApplicationXtender imports the page and attaches it to the 
displayed document.

Note: The Save button is inaccessible. The database is automatically 
updated without any additional action from the user.

Attach a page to a document not displayed in 
ApplicationXtender Document Manager

Use the following steps in ApplicationXtender Document Manager to attach an unindexed 
page to a document that is indexed but not currently displayed.

1. After you scan or import a new file into ApplicationXtender, make sure that the newly 
added page is displayed with the index grid.

2. Press F4 or Shift+F4 to look up existing records. The Result Set list is displayed.

Note: F4 searches against existing records. Shift+F4 searches against 
unused key reference records and existing records

3. Select the document that is associated with the unindexed page.

4. Click Attach. ApplicationXtender populates index values in the grid and adds the page 
to the existing document.

Note: The Copy Index button copies most index values of an existing 
document into the index grid of a new document. If you use this feature, 
the document type should be different from the original index.

Attach a page to a document displayed in 
ApplicationXtender Web Access

Use the following steps in ApplicationXtender Web Access to attach a page to a document 
that is not currently displayed.

1. After you scan or import a new file into ApplicationXtender, make sure that the existing 
document is displayed.

2. Select Page > New Page. The Add New Page dialog box is displayed.

3. Select an option from the New Page Insertion Point drop-down list.

4. Enter a file path, or click Browse to locate the page that you want to add to the 
selected document.

5. Click UPLOAD. ApplicationXtender loads the page and adds to the displayed 
document.
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Using Context Rules and Queries

Banner® uses rule-based functionality to launch a query within ApplicationXtender. The 
query results are based on the location of the cursor on a Banner form and, potentially, the 
data values in key specific fields on that form. Context rules link the behavior of integrated 
ApplicationXtender to the cursor location on a Banner form.

Banner is delivered with several hundred pre-defined rules that represent integration 
behaviors found to be most desirable. Your institution can change or remove these rules, if 
they are inaccurate representations of your processing style.

Refer to the Banner Document Management Administration Guide for more information 
about context rules.

Context rules

Context rules are based on the cursor location (context) on a Banner form. When you click 
the BDM - Display Document button on the Banner toolbar, ApplicationXtender 
Document Manager or ApplicationXtender Web Access is launched and a query is run, 
based on the location of the cursor on the form.Typically, the parameters of the query 
include an ID, the document type to be retrieved, and other key pieces of data, such as 
term code or aid year.

There are four levels of context rules in BDM:

• Form-level rules run a query from any location on the Banner form.

• Block-level rules run a query from any location within a specified block on a Banner 
form.

• Item-level rules run a query from a specified field on a Banner form.

• Item-value-level rules run a query based on the value of the specified field on a Banner 
form.

The priority of rules, from lowest to highest is form, block, item, and item-value. A rule can 
be superseded by another rule that has higher priority. If two or more rules apply to a 
cursor location, the highest priority rule takes precedence. For example, if an item-level 
rule and block-level rule apply to a specific field, the item-level rule has higher priority and 
is used to run the query.
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Example 1 (form-level rule)

Clicking the BDM - Display Document button anywhere on SPAPERS queries the B-S-ID 
application for all document types. The absence of a specific value acts as a wild card.

Example 2 (block-level rule)

Clicking the BDM - Display Document button anywhere in the SARADAP block on 
SAAADMS queries the B-S-ADMN application for the Admission Application document 
type.

Example 3 (item-level rule)

Clicking the BDM - Display Document button in the SPBPERS_SSN field of the 
SPBPERS block on SPAPERS queries the B-S-ID application for the Social Security Card 
document type. 

Form 
Name

Block 
Name

Item 
Name

Item 
Value

BDM 
Application

Document 
Type

SPAPERS B-S-ID

Form 
Name

Block 
Name

Item 
Name

Item 
Value

BDM 
Applicatio
n

Document 
Type

SAAADMS SARADAP B-S-ADMN ADMISSIONS 
APP

Form 
Name

Block 
Name

Item 
Name

Item 
Value

BDM 
Application

Document 
Type

SPAPERS SPBPERS SPBPERS_
SSN

B-S-ID SSN CARD
  24M 8.7.0.6 User Guide with AX 16.3 | Using Context Rules and Queries 



BD
Example 4 (item-value-level rule)

Clicking the BDM - Display Document button in the SPBPERS_DEAD_IND field when it 
has a field value of Y in the SPBPERS block on SPAPERS queries the B-S-ID application 
for the Death Notice Documentation document type. 

Queries

You can quickly search for a document or image by querying ApplicationXtender from 
Banner.

Run a query from Banner

Use the following steps to query ApplicationXtender from Banner.

1. Access the appropriate form in Banner.

2. If the query can be executed at block-level, item-level, or item-value-level, place the 
cursor at the appropriate location on the form.

3. Click BDM - Display Document . Results are displayed in ApplicationXtender 
Document Manager or ApplicationXtender Web Access.

A query from most key blocks returns a set of documents related only by ID. Most forms 
are delivered with a key block-level context rule that searches the associated B-%-ID 
application using ID as a parameter. 

Note: The ampersand (%) represents a Banner functional area (product).

Form 
Name

Block 
Name

Item 
Name

Item 
Value

BDM 
Application

Document 
Type

SPAPERS SPBPERS SPBPERS_
DEAD_IND

Y B-S-ID DEATH NOTICE
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Count matched documents from Banner

Use the following steps to count the number of documents that match the query 
parameters.

Note: If no context rule is setup for the Banner form, then the query uses 
default application B-G-ID.

1. Access the appropriate form in Banner.

2. If the query can be executed at block-level, item-level, or item-value-level, place the 
cursor at the appropriate location in the form.

3. Select Tools > Banner Document Management > Count Matched Documents. A 
count of documents that match the query parameters is displayed.

The specific information that is passed to ApplicationXtender Document Manager or 
ApplicationXtender Web Access is determined by the context rule that is defined for the 
form, block, or item where your cursor is located. The count returned by the query 
depends on your location within the form.
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Using Banner Requirements Linking

Banner® requirements linking is the functionality within Banner Document Management 
(BDM) where a Banner table is updated automatically when documents are indexed in 
BDM. This functionality is provided in the following BDM applications:

• B-R-TREQ (Financial Aid Tracking Requirement)

• B-S-ADMN (Student Admissions)

Indexing a document in one of these BDM applications essentially marks the Banner 
record as “received.” There is no need to manually update Banner.

Refer to the Banner Document Management Administration Guide for more details about 
requirements linking.

Financial aid tracking requirements

Within Banner Financial Aid, the tracking requirements checklist includes the documents 
that are required for a financial aid application (for example, a savings statement). When a 
required document is indexed in ApplicationXtender, tracking requirements on the 
Applicant Requirements Form (RRAAREQ) are updated automatically.

The BDM administrator uses the Document Management FinAid Requirements Linking 
Form (ERALINK) to define the rules that apply when indexed financial aid documents 
create or update tracking requirements in Banner. Refer to the Banner Document 
Management Administration Guide for details on configuring the linking rules. You should 
review the rules with your BDM administrator to understand the relationship between 
Banner and the documents that are maintained within BDM.

Requirements can be updated as needed or removed from Banner if the requirement is no 
longer applicable.

Policies regarding the use of requirements tracking vary by institution. You should know 
how your site has configured this feature.

Insert requirements

B-R-TREQ can create a new requirement into the Banner database when a document is 
received.

Based on the Banner linking rules configured on ERALINK, and additional BDM settings 
configured by the system administrator, a new document may be identified by its index 
values as a requirement. If that record does not yet exist on the RRRAREQ table, a new 
tracking requirement record is inserted into the appropriate table when the document 
index is saved.
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The insertion of a new tracking requirement in the RRRAREQ table depends on 
requirements linking rules that stipulate that the tracking requirement (in the RTVTREQ 
table) must be active. If the tracking requirement has a fund assigned to it, then the fund 
(in the RFRBASE table) must also be active. If either is inactive, then the BDM 
requirements linking process does not insert a tracking requirement into RRRAREQ and 
the document index is not saved. The BDM linking rules on ERALINK also depend on the 
tracking requirement active indicator and the fund code active indicator.

Delete requirements

A subsequent deletion of a BDM document rolls back the Banner record to a value that is 
defined in the linking rule on ERALINK. An exception to this rule is that financial aid 
tracking requirement status values might not be restored if any of the following conditions 
exists:

• The document is not the only document that could have updated the status of the 
tracking requirement.

• The requirement type is one for which Banner’s “Satisfy All” indicator was set on the 
Tracking Validation Form (RTVTREQ) and the requirement’s status was set indirectly, as 
a result of BDM satisfaction of another occurrence of the requirement within the same 
aid year.

• The requirement type is one for which Banner’s “Once” indicator was set on RTVTREQ 
and the requirement’s status was set indirectly, as a result of BDM satisfaction of 
another occurrence of the requirement within another aid year.

If a document was linked to a requirement that is considered “Satisfy All” or “Once” and 
the document is deleted, you must review the tracking requirements on RRAAREQ and 
manually reset status values for any incorrect items. Failure to do so might result in 
inaccurate Banner data and, potentially, the improper distribution of funds.

Requirements linking in a MEP environment

The VPDI_CODE index field supports the Database Extension Utility and Multi-Entity 
Processing (MEP). This text field is used in a MEP environment to identify the campus or 
institution code to which a document index is assigned. This field corresponds to the 
VPDI_CODE field in a Banner table record in a MEP environment.

If your institution uses MEP and has enabled the RRRAREQ table for MEP, then the BDM 
application B-R-TREQ must also be enabled for MEP. In this case, BDM updates or 
inserts the financial aid tracking requirement based on the VPDI_CODE assigned to the 
tracking requirement record.

For details about the update of financial aid tracking requirements in a MEP environment, 
refer to the Banner Document Management Multi-Entity Processing Implementation 
Guide.
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Student admissions requirements

Within Banner Student, the admissions requirements checklist includes the documents 
that are required for an admissions application (for example, a high school transcript). 
When a required document is indexed in ApplicationXtender, admissions requirements on 
the Admissions Application Form (SAAADMS) are updated automatically.

The BDM administrator uses the BDM Student Admission Requirements Linking Form 
(ESALINK) to define the rules that apply when indexed admissions documents create or 
update requirements in Banner. Document types can be linked to specific checklist 
requirements. Refer to the Banner Document Management Administration Guide for 
details on configuring the linking rules You should review the rules with your BDM 
administrator to better understand the relationship between Banner and the documents 
maintained within BDM.

When a document is indexed in BDM, an admissions requirement is marked as “received” 
using values that meet the criteria in the linking rule. Depending on the configuration of the 
rule, updates can occur in one of the following scenarios:

• A specific request type in a specific application, for a specific term

• A specific request type in all applications, for a specific term

• All occurrences of the request type, regardless of term

Each time a Banner record is updated through ApplicationXtender, a message alerts you 
that activity in B-S-ADMN updated, inserted, or deleted Banner information. This message 
can be turned off by the BDM administrator.

Requirements can be updated as needed or removed from Banner if the requirement is no 
longer applicable. Removal of a requirement in Banner will not delete the document in 
BDM. You must delete the document manually.

Policies regarding the use of admissions requirements vary by institution. You should 
know how your site has configured this feature.

Insert requirements

B-S-ADMN can create a new requirement into the Banner database upon receipt of a 
document. 

Based on the Banner linking rules configured on ESALINK, and additional BDM settings 
configured by the system administrator, a new document may be identified as a 
requirement based on its index values. If that record does not yet exist on the SARCHKL 
table, a new requirements record is inserted into the appropriate table when the document 
index is saved.
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Delete requirements

Admissions requirements roll back to an unsatisfied state if the supporting BDM document 
is deleted or changed in such a way that its index no longer matches the requirement. The 
BDM administrator can use linking rules to enable or disable this capability. Rollback only 
takes place when all of the following conditions are true:

• The index was deleted or changed in such a way that it no longer fulfills the requirement.

• The BDM administrator enabled the undo capability at both the global and rule levels.

• No other BDM documents exist that continue to support the individual requirement’s 
satisfaction.

Requirements linking in a MEP environment

The VPDI_CODE index field supports the Database Extension Utility and Multi-Entity 
Processing (MEP). This text field is used in a MEP environment to identify the campus or 
institution code to which a document index is assigned. This field corresponds to the 
VPDI_CODE field in a Banner table record in a MEP environment.

If your institution uses MEP and has enabled the SARCHKL table for MEP, then the BDM 
application B-S-ADMN must also be enabled for MEP. In this case, BDM updates or 
inserts the student admissions requirements based on the VPDI_CODE assigned to the 
student admissions requirement record.

For details about BDM updating of student admissions requirements in a MEP 
environment, refer to the Banner Document Management Multi-Entity Processing 
Implementation Guide.
  30M 8.7.0.6 User Guide with AX 16.3 | Using Banner Requirements Linking 



BD
Security

Data contained in Banner® Document Management (BDM) can be protected by the 
following security methods.

Document level security

Document level security allows you to enable or to limit access to specific information on a 
group-by-group basis. Document level security is established for individual fields of 
applications by using ApplicationXtender Application Generator.

For more information, refer to the Banner Document Management Administration Guide.

Banner security

The same methods of security that are used within Banner are enforced within BDM. 
Multiple security methods provide a “layered” security system. Each method operates 
independently from the others. A denial of access in any one method results in a complete 
denial of access to the document, regardless of success in another method. Information 
about denial of access is displayed on the screen at the time of denial and recorded in the 
BDM Error Results table (EXRRSLT).

Although BDM does not support multiple indexes, baseline ApplicationXtender can be 
configured to allow multiple indexes for a document. If multiple indexes exist, then the 
security methodology is applied to each case. A denial of access in any one case results 
in denial of access for all cases of the document.

Banner Finance

If fund/organization security is enabled for Banner Finance, this level of security is 
enforced on BDM documents in the BDM Finance applications. This level of security is 
controlled through Banner, not through BDM. 

When a query is performed, all matching documents are displayed. If, however, you try to 
access a document and you do not have the appropriate access rights for the document, a 
fund/organization security message is displayed in ApplicationXtender Document 
Manager or ApplicationXtender Web Access. Although the message indicates that an 
error occurred, the true nature of the event is that during the course of opening the file, the 
Banner fund/organization security test failed.
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Banner Human Resources

If security is enabled for Banner Human Resources, this level of security is enforced on 
BDM documents in the BDM Human Resources applications. This level of security is 
controlled through Banner, not through BDM. 

When a query is performed, all matching documents are displayed. If, however, you try to 
access a document and you do not have the appropriate access rights for the document, a 
security message is displayed in ApplicationXtender Document Manager or 
ApplicationXtender Web Access. Although the message indicates that an error occurred, 
the true nature of the event is that during the course of opening the file, the Banner Human 
Resources security test failed.
  32M 8.7.0.6 User Guide with AX 16.3 | Security 



BD
Glossary

Annotation

A markup, typically a note or highlight, that is applied to an image to focus attention on 
a particular part of the page.

Auto index system

A lookup feature that contains examples of repeating Banner® data related to a 
common ID.

Banner Document Management (BDM)

Combination of ApplicationXtender Document Manager and/or ApplicationXtender 
Web Access with all Banner software to integrate the products into a functional model 
where Banner can drive ApplicationXtender.

BDM application

Index-driven data storage structure where documents can be stored and retrieved.

BDM - Add Document 

Button on the Banner toolbar that opens ApplicationXtender Document Manager or 
ApplicationXtender Web Access so that a new ApplicationXtender document can be 
created from data stored in Banner.

BDM - Display Document 

Button on the Banner toolbar that opens ApplicationXtender Document Manager or 
ApplicationXtender Web Access so that a query can be performed.

Context 

Location within a Banner form where the cursor is located when you click the BDM 
button to access ApplicationXtender and create a query.

Data reference field

Field that provides data that is derived from a single key reference field. For example, 
LAST NAME (data reference field) is derived from ID (key reference field).
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Data source

Container for connection information that enables an application to connect to and 
receive data from a particular database.

Document

File or group of files stored in an application and identified by a unique set of index 
information. Each page of a document is a single object, such as a scanned image file 
or a word processing document. A document can be small (one page) or large 
(thousands of pages).

Document type

User-defined code that identifies each type of document that is stored and indexed in 
a BDM application.

OpenText

The Ellucian partner for the integrated BDM solution.

Index

Group of fields where information relating to a documents is stored. When a document 
is stored in an application, the index values that you enter identify the document.

Key reference system

A lookup table that contains data used frequently during the indexing process.

Multi-Entity Processing (MEP)

An environment that enables two or more entities (institutions or campuses) to coexist 
in a single application architecture. MEP uses Oracle’s Virtual Private Database 
functionality to implement the policies required for this coexistence.

Page

Single object within a document. Each page of a document shares the document’s 
index values.

Requirements linking

Rules that facilitate the update of financial aid tracking requirements and student 
admissions requirements based on activity in BDM.

VPD

Oracle’s Virtual Private Database, which implements row-level security using Fine 
Grained Access Control (FGAC) for user-defined security policies. This allows data 
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segregation by campus, institution, or entity using the VPDI_CODE column (index 
field) in Banner and ApplicationXtender tables.
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